IPython 官方存储库 包含网站、文档构建等内容-Python 实用宝典

IPython 官方存储库 包含网站、文档构建等内容

IPython:高效交互计算

概述

欢迎来到IPython。有关我们的完整文档,请访问ipython.readthedocs.io并包含有关如何安装、使用和参与项目的信息。IPython(交互式Python)是用于多种编程语言交互计算的命令shell,最初是为Python编程语言开发的,它提供自检、富媒体、shell语法、制表符完成和历史记录

IPython版本和Python支持

从IPython 7.10开始,IPython紧随其后NEP 29

IPython 7.17+需要Python版本3.7及更高版本

IPython 7.10+需要Python 3.6版和更高版本

IPython 7.0需要Python 3.5版和更高版本

IPython 6.x需要Python 3.3版和更高版本

IPython 5.x LTS是与Python2.7兼容的版本。如果您需要Python 2支持,您可以必须使用IPython 5.x LTS。请根据需要更新您的项目配置和要求

笔记本、Qt控制台和许多其他部件现在是朱庇特请参阅Jupyter installation docs如果你想用这些

IPython的主要功能

全面的对象自省

输入历史记录,跨会话持久

在具有自动生成的引用的会话期间缓存输出结果

可扩展的制表符完成,默认情况下支持完成python变量和关键字、文件名和函数关键字

可扩展的“魔术”命令系统,用于控制环境并执行许多与IPython或操作系统相关的任务

丰富的配置系统,可在不同设置之间轻松切换(比每次更改$PYTHONSTARTUP环境变量更简单)

会话记录和重载

用于特殊目的情况的可扩展语法处理

访问具有用户可扩展别名system的系统外壳

可轻松嵌入到其他Python程序和GUI中

对PDB调试器和Python探查器的集成访问

开发与即时运行

您可以在上找到最新版本的开发文档readthedocs

通过在终端键入以下命令,甚至无需在系统范围内安装IPython,即可从该目录运行IPython:

$ python -m IPython

或查看development installation docs有关最新版本的信息,请阅读文档

旧版本IPython的文档和安装说明可在IPython website

IPython需要Python版本3或更高版本

从版本6.0开始,IPython不支持Python 2.7、3.0、3.1或3.2

要获得与Python 2.7兼容的版本,请安装5.x LTS长期支持版本

如果您遇到此错误消息,您可能正在尝试从源代码安装或使用IPython。您需要检查远程5.x分支机构。如果您使用的是GIT,则应该可以执行以下操作:

$ git fetch origin
$ git checkout 5.x

如果您在常规安装IPython时遇到此错误消息,则可能需要更新包管理器,例如,如果您使用的是pip,请使用以下命令检查pip的版本:

$ pip --version

您需要将pip更新到9.0.1版或更高版本。如果您使用的不是pip,请向软件包的维护人员咨询您的软件包管理器。

有关更多信息,请参阅我们的博客帖子之一:

https://blog.jupyter.org/release-of-ipython-5-0-8ce60b8d2e8e

以及以下拉式请求以供讨论:

https://github.com/ipython/ipython/pull/9900

如果您正在调用setup.py直接-这是您不应该使用的-使用或正在使用easy_install如果是这种情况,请使用pip
install .
而不是setup.py install,以及pip install -e .而不是setup.py develop如果您依赖IPython作为依赖项,则可能还希望对IPython具有条件依赖项,具体取决于Python版本:

install_req = ['ipython']
if sys.version_info[0] < 3 and 'bdist_wheel' not in sys.argv:
    install_req.remove('ipython')
    install_req.append('ipython<6')

setup(
    ...
    install_requires=install_req
)

IPython的替代方案

IPython可能不合您的口味;如果是这样,您可能想要使用类似的项目:

忽略带有git故障的提交。忽略reRevsFile

从GIT 2.23开始,可以在不中断的情况下进行格式更改git blame请参阅git documentation有关更多详细信息,请参阅

要使用此功能,您必须:

  • 安装Git>=2.23
  • 通过运行以下命令配置您的本地GIT存储库:
    • POSIX:tools\configure-git-blame-ignore-revs.sh
    • 窗口:tools\configure-git-blame-ignore-revs.bat
本文由 Python 实用宝典 作者:Python实用宝典 发表,其版权均为 Python 实用宝典 所有,文章内容系作者个人观点,不代表 Python 实用宝典 对观点赞同或支持。如需转载,请注明文章来源。
2

抱歉,评论已关闭!