python教程—如何使用requirements.txt在python项目中安装所有依赖项-Python实用宝典

python教程—如何使用requirements.txt在python项目中安装所有依赖项

我是python新手。最近我得到了一个由python编写的项目,它需要一些安装。我运行下面的命令安装,但得到一个错误。

我是python新手。最近我得到了一个由python编写的项目,它需要一些安装。我运行下面的命令安装,但得到一个错误。

    # pip install requirements.txt Collecting requirements.txt Could not find a version that satisfies the requirement requirements.txt (from versions: ) No matching distribution found for requirements.txt

我在谷歌上搜索了一下,找到了这个链接http://stackoverflow.com/questions/28167987/ pythonpip - problem -install -from-requirements-txt,但是我不太明白那篇文章中的解决方案是什么。

下面是我的requirements.txt文件:

    # cat requirements.txt ordereddict==1.1 argparse==1.2.1 python-dateutil==2.2 matplotlib==1.3.1 nose==1.3.0 numpy==1.8.0 pymongo==3.3.0 psutil>=2.0

是否有一种简单的方法来安装这个python项目中所需的所有依赖项?

<强> EDIT1 < /强>

下面是pip3 install -r requirements.txt的输出。

    # pip3 install -r requirements.txt Requirement already satisfied: ordereddict==1.1 in /usr/local/lib/python3.5/dist-packages (from -r requirements.txt (line 1)) Collecting argparse==1.2.1 (from -r requirements.txt (line 2)) Using cached argparse-1.2.1.tar.gz Collecting python-dateutil==2.2 (from -r requirements.txt (line 3)) Using cached python-dateutil-2.2.tar.gz Collecting matplotlib==1.3.1 (from -r requirements.txt (line 4)) Using cached matplotlib-1.3.1.tar.gz Complete output from command python setup.py egg_info: ============================================================================ Edit setup.cfg to change the build options BUILDING MATPLOTLIB matplotlib: yes [1.3.1] python: yes [3.5.2 (default, Nov 17 2016, 17:05:23) [GCC 5.4.0 20160609]] platform: yes [linux] REQUIRED DEPENDENCIES AND EXTENSIONS numpy: yes [version 1.11.3] dateutil: yes [using dateutil version 2.6.0] tornado: yes [tornado was not found. It is required for the WebAgg backend. pip/easy_install may attempt to install it after matplotlib.] pyparsing: yes [using pyparsing version 2.1.10] pycxx: yes [Official versions of PyCXX are not compatible with Python 3.x. Using local copy] libagg: yes [pkg-config information for 'libagg' could not be found. Using local copy.] freetype: no [The C/C++ header for freetype2 (ft2build.h) could not be found. You may need to install the development package.] png: yes [pkg-config information for 'libpng' could not be found. Using unknown version.] OPTIONAL SUBPACKAGES sample_data: yes [installing] toolkits: yes [installing] tests: yes [using nose version 1.3.7] OPTIONAL BACKEND EXTENSIONS macosx: no [Mac OS-X only] qt4agg: no [PyQt4 not found] gtk3agg: no [gtk3agg backend does not work on Python 3] gtk3cairo: no [Requires cairo to be installed.] gtkagg: no [Requires pygtk] tkagg: no [TKAgg requires Tkinter.] wxagg: no [requires wxPython] gtk: no [Requires pygtk] agg: yes [installing] cairo: no [cairo not found] windowing: no [Microsoft Windows only] OPTIONAL LATEX DEPENDENCIES dvipng: no ghostscript: no latex: no pdftops: no ============================================================================ * The following required packages can not be built: * freetype ---------------------------------------- Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-don4ne_2/matplotlib/

我已经安装了libfreetype6-dev,但是pip命令仍然报告缺少这个依赖项。

    # apt-get install libfreetype6-dev Reading package lists... Done Building dependency tree Reading state information... Done libfreetype6-dev is already the newest version (2.6.1-0.1ubuntu2). 0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.

回答

如果你正在使用Linux操作系统:

  1. 从requirements.txt中删除matplotlib==1.3.1
  2. 尝试用sudo apt-get install python-matplotlib安装
  3. 运行pip install -r requirements.txt (python2)或pip3 install -r requirements.txt (python3)
  4. 皮普冻结在让

如果你使用的是Windows操作系统:

  1. python -m pip安装-U pip setup工具
  2. python -m pip安装matplotlib

​Python实用宝典 (pythondict.com)
不只是一个宝典
欢迎关注公众号:Python实用宝典

本文由 Python实用宝典 作者:Python实用宝典 发表,其版权均为 Python实用宝典 所有,文章内容系作者个人观点,不代表 Python实用宝典 对观点赞同或支持。如需转载,请注明文章来源。
0

发表评论