python教程—如何编写正确要求最小Python版本的Python代码?-Python实用宝典

python教程—如何编写正确要求最小Python版本的Python代码?

我想看看是否有任何方法需要一个最小的python版本。由于新的异常处理(作为关键字),我有几个python模块需要python 2.6。

我想看看是否有任何方法需要一个最小的python版本。

由于新的异常处理(作为关键字),我有几个python模块需要python 2.6。

看起来,即使我在脚本的开头检查python版本,代码也不会运行,因为解释器将在模块中失败,抛出一个丑陋的系统错误,而不是告诉用户使用新的python。

回答

    import sys if sys.hexversion < 0x02060000: sys.exit("Python 2.6 or newer is required to run this program.") import module_requiring_26

还有一点很酷,它可以包含在_init__文件或模块中。

​Python实用宝典 (pythondict.com)
不只是一个宝典
欢迎关注公众号:Python实用宝典

本文由 Python实用宝典 作者:Python实用宝典 发表,其版权均为 Python实用宝典 所有,文章内容系作者个人观点,不代表 Python实用宝典 对观点赞同或支持。如需转载,请注明文章来源。
1

发表评论