python教程—目标数据库不是最新的-Python实用宝典

python教程—目标数据库不是最新的

我想做一个弗拉斯克应用程序迁移。我正在使用Alembic。但是,我收到以下错误。

我想做一个弗拉斯克应用程序迁移。我正在使用Alembic。

但是,我收到以下错误。

Target database is not up to date.

在网上,我读到这与此有关。
http://alembic.zzzcomputing.com/en/latest/cookbook.html#build -an-up- date-database-from-scratch

不幸的是,我不太明白如何使数据保持最新,以及在何处/如何编写链接中给出的代码。如果你有移民的经验,你能给我解释一下吗

谢谢

回答

在手动或as -autogenerate创建迁移之后,必须使用alembic升级头应用它。如果使用shell中的db.create_all(),可以使用alembic stamp head来表示数据的当前状态表示所有迁移的应用程序。

​Python实用宝典 (pythondict.com)
不只是一个宝典
欢迎关注公众号:Python实用宝典

本文由 Python实用宝典 作者:Python实用宝典 发表,其版权均为 Python实用宝典 所有,文章内容系作者个人观点,不代表 Python实用宝典 对观点赞同或支持。如需转载,请注明文章来源。
0

发表评论