python教程—pip安装pygraphviz:没有包“libcgraph”发现-Python实用宝典

python教程—pip安装pygraphviz:没有包“libcgraph”发现

我成功安装graphviz和cgraph与我遇到的问题没有包'libcgraph'发现运行sudo pip安装pygraphviz。下面是完整的堆栈跟踪。

我成功安装graphviz和cgraph with

    $ sudo pip install graphviz .... Successfully installed graphviz-0.5.1 $ sudo pip install cgraph ... Successfully installed cgraph-0.1

我遇到的问题没有包'libcgraph'发现运行sudo pip安装pygraphviz。下面是完整的堆栈跟踪。

    $ sudo pip install pygraphviz The directory '/Users/sparkandshine/Library/Caches/pip/http' or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag. The directory '/Users/sparkandshine/Library/Caches/pip' or its parent directory is not owned by the current user and caching wheels has been disabled. check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag. Collecting pygraphviz Downloading pygraphviz-1.3.1.zip (123kB) 100% |████████████████████████████████| 133kB 1.5MB/s Installing collected packages: pygraphviz Running setup.py install for pygraphviz ... error Complete output from command /usr/bin/python -u -c "import setuptools, tokenize;__file__='/private/tmp/pip-build-qfFpFG/pygraphviz/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('rn', 'n');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-JmwjA6-record/install-record.txt --single-version-externally-managed --compile: running install Trying pkg-config Package libcgraph was not found in the pkg-config search path. Perhaps you should add the directory containing `libcgraph.pc' to the PKG_CONFIG_PATH environment variable No package 'libcgraph' found Traceback (most recent call last): File "<string>", line 1, in <module> File "/private/tmp/pip-build-qfFpFG/pygraphviz/setup.py", line 87, in <module> tests_require=['nose>=0.10.1', 'doctest-ignore-unicode>=0.1.0',], File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/distutils/core.py", line 151, in setup dist.run_commands() File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/distutils/dist.py", line 953, in run_commands self.run_command(cmd) File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/distutils/dist.py", line 972, in run_command cmd_obj.run() File "setup_commands.py", line 44, in modified_run self.include_path, self.library_path = get_graphviz_dirs() File "setup_extra.py", line 121, in get_graphviz_dirs include_dirs, library_dirs = _pkg_config() File "setup_extra.py", line 44, in _pkg_config output = S.check_output(['pkg-config', '--libs-only-L', 'libcgraph']) File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/subprocess.py", line 573, in check_output raise CalledProcessError(retcode, cmd, output=output) subprocess.CalledProcessError: Command '['pkg-config', '--libs-only-L', 'libcgraph']' returned non-zero exit status 1 ---------------------------------------- Command "/usr/bin/python -u -c "import setuptools, tokenize;__file__='/private/tmp/pip-build-qfFpFG/pygraphviz/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('rn', 'n');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-JmwjA6-record/install-record.txt --single-version-externally-managed --compile" failed with error code 1 in /private/tmp/pip-build-qfFpFG/pygraphviz/

我尝试了

回答

    sudo apt-get install python-dev graphviz libgraphviz-dev pkg-config

然后

    sudo pip install pygraphviz

​Python实用宝典 (pythondict.com)
不只是一个宝典
欢迎关注公众号:Python实用宝典

本文由 Python实用宝典 作者:Python实用宝典 发表,其版权均为 Python实用宝典 所有,文章内容系作者个人观点,不代表 Python实用宝典 对观点赞同或支持。如需转载,请注明文章来源。
2

发表评论